Inbound and Outbound SMS and MMS Delivery Delays to/from US and Canada Networks
Incident Report for Bringg
Resolved
We are observing a full recovery in message delivery to/from US and Canada networks and delivery receipts.
Posted Jan 15, 2022 - 03:35 UTC
Update
We are observing full recovery in message delivery to/from US and Canada networks and delivery receipts. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 15, 2022 - 01:59 UTC
Update
We continue to observe a noticeable recovery after the implementation of the workaround, though we continue to see intermittent delivery delays sending and receiving messages in US and Canada.

The issue is also causing delivery receipts to be delayed, with delivery status stuck at "Sent".
The communications platform's engineering team is continuing work to fully resolve the issue.
We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 14, 2022 - 23:25 UTC
Update
We continue to observe a noticeable recovery after the implementation of the workaround, though we continue to see intermittent delivery delays sending and receiving messages in US and Canada.

The issue is also causing delivery receipts to be delayed, with delivery status stuck at "Sent".
The communications platform's engineering team is continuing work to fully resolve the issue.
We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 14, 2022 - 22:38 UTC
Update
We continue to observe a noticeable recovery after the implementation of the workaround, though we continue to see intermittent delivery delays sending and receiving messages in US and Canada.

The issue is also causing delivery receipts to be delayed, with delivery status stuck at "Sent".
The communications platform's engineering team is continuing work to fully resolve the issue.
We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 14, 2022 - 21:45 UTC
Monitoring
Our communications platform has observed a noticeable recovery after the implementation of the workaround, though we continue to see intermittent delivery delays sending and receiving messages in US and Canada.

The issue is also causing delivery receipts to be delayed, with delivery status stuck at "Sent".
The communications platform's engineering team is continuing work to fully resolve the issue.
We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 14, 2022 - 20:43 UTC
Identified
We are now observing some recovery in which some messages to/from US and Canada networks are being delivered. The communication platform's engineers have identified the issue and implemented a workaround for older messages.

However, message deliveries will continue to be delayed even while messages are getting delivered.
We are continuing to work with our communication platform partner to resolve the issue.
We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 14, 2022 - 16:55 UTC
Update
We are continuing to investigate this issue.
Posted Jan 14, 2022 - 16:05 UTC
Investigating
Our communications platform is experiencing delivery delays when sending SMS and MMS messages to US and Canada networks. We are working with their team to resolve the issue. We will provide another update as soon as more information becomes available.
Posted Jan 14, 2022 - 15:36 UTC
This incident affected: US2-GCP (Access / Authentication (US2-GCP), API / Integrations (US2-GCP), Customer Experience (US2-GCP), Delivery Partners (US2-GCP), Dispatch Interface / Dashboard (US2-GCP), Driver App (US2-GCP), Geolocation / Tracking (US2-GCP), Infrastructure (US2-GCP), Notifications (US2-GCP), Reporting (US2-GCP)) and US1-AWS (Access / Authentication (US1-AWS), API / Integrations (US1-AWS), Customer Experience (US1-AWS), Delivery Partners (US1-AWS), Dispatch Interface / Dashboard (US1-AWS), Driver App (US1-AWS), Geolocation / Tracking (US1-AWS), Infrastructure (US1-AWS), Notifications (US1-AWS), Reporting (US1-AWS)).